2 bugs I can't sort with ActiveAdmin
1
Not solved Solved
over 1 year ago

"Hello all, I have added ActiveAdmin in my app (i was already using devise). I have 2 bugs that I can’t seem to sort, and I don’t know if they are connected. FIRST, when I make any kind of changes in a file related to activeadmin and I try to refresh the web page right after (in activeadmin), i get the error message \"A copy of ApplicationController has been removed from the module tree but is still active! ». SECOND, when I am in my activeadmin interface, I can create / update / destroy all the models I decided to generate resource for, but I have problems with the user: I can not update existing users, even their name, or email adress. When I try this, the activeadmin interface just gets « stuck », and the update is not working.\n\nIn the meantime, this is what happens in the rails s when I try to update a user:\n\nStarted PATCH \"/admin/users/1\" for ::1 at 2015-10-07 11:56:05 +0200\nProcessing by Admin::UsersController#update as HTML\n Parameters: {\"utf8\"=>\"✓\", \"authenticitytoken\"=>\"brqAn0Uwov0hddNeTjtWYo/By9K3iNu7wdFR94zvTzCa0LHseNO4efmAPeZMHDGfS5Na5bCtVDhdcrQM03Pd0A==\", \"user\"=>{\"name\"=>\"bob\", \"email\"=>\"dim@dim.com\"}, \"commit\"=>\"Update User\", \"id\"=>\"1\"}\n User Load (0.3ms) SELECT \"users\".* FROM \"users\" WHERE \"users\".\"id\" = $1 ORDER BY \"users\".\"id\" ASC LIMIT 1 [[\"id\", 3]]\n Cart Exists (0.3ms) SELECT 1 AS one FROM \"carts\" WHERE \"carts\".\"userid\" = $1 LIMIT 1 [[\"userid\", 3]]\n Cart Load (0.2ms) SELECT \"carts\".* FROM \"carts\" WHERE \"carts\".\"userid\" = $1 ORDER BY \"carts\".\"id\" DESC LIMIT 1 [[\"userid\", 3]]\n User Load (0.3ms) SELECT \"users\".* FROM \"users\" WHERE \"users\".\"id\" = $1 LIMIT 1 [[\"id\", 1]]\n (0.2ms) BEGIN\n (0.2ms) ROLLBACK\n Rendered /Users/dimitriboukobza/.rbenv/versions/2.2.2/lib/ruby/gems/2.2.0/bundler/gems/activeadmin-06bf79c58216/app/views/activeadmin/resource/edit.html.arb (1828.5ms)\n\nANY IDEAS??? Thanks a lot!"

over 1 year ago

I saw this SO question, but I can't find the solution here. I tried the config.skipbeforefilter :something as I have 2 variables that are calculated in my app controller, but it does not change anything.

over 1 year ago

Have you ever had this issue?

Cancel
Submit your answer