Sidekiq with heroku and redis. Cannot process jobs. Any idea ?
3
Not solved Solved
10 months ago

Hey guys !

I have configured Sidekiq in order to make regular API calls (from Typeform). It works fine in development, but in production not : jobs are stuck enqueued but not processed.

Google suggests that it might be due to the fact that Sidekiq looks in the wrong queue, but I have configured everything according to karr.lewagon, including the specification worker: bundle exec sidekiq -C config/sidekiq.yml in the Procfile, which specifies the queues to be used (the default one in this case). And I guess it does not come from Redis config, since the jobs are correctly enqueued, right ?

I must admit that I am quite lost... any idea would be of great help ! :)

Many thanks to you all :)

10 months ago

Hey, if you want to check the queues you can : Sidekiq::Queue.new('queue_name').size and if you want to check the scheduled jobs : Sidekiq::ScheduledSet.new.size Those commands can help you to check what is enqueued and what is scheduled. If it is enqueued but not process so you can track sidekiq logs where you could read the errors messages.

10 months ago

Did you scale your dynos so that at least one dyno is running the worker command defined in your Procfile?

heroku ps
heroku ps:scale --help   
10 months ago

Thank you ssaunier, that was the issue. Problem solved, hurra !!! :D

Cancel
Submit your answer