Openstack Ovh connection configuration
1
Not solved Solved
7 months ago

I am currently working on a rails app and I want to use Openstack with object storage from OVH.

My error is : connectnonblock': SSLconnect returned=1 errno=0 state=unknown state: certificate verify failed (OpenSSL::SSL::SSLError) Unable to verify certificate. This may be an issue with the remote host or with Excon.Excon has certificates bundled, but these can be customized.Excon.defaults[:sslcapath] = pathtocerts,ENV['SSLCERTDIR'] = pathtocerts,Excon.defaults[:sslcafile] = pathtofile,ENV['SSLCERTFILE'] = pathtofile,Excon.defaults[:sslverifycallback] = callback(see OpenSSL::SSL::SSLContext#verifycallback), orExcon.defaults[:sslverify_peer] = false` (less secure). (Excon::Errors::CertificateError)

Does anyone have a solution to do it ?

I have followed this tutorial in french: https://gist.github.com/BaptisteDixneuf/85dc4419a0398446d2d3

and there is my carrierwave config file :

CarrierWave.configure do |config|
 config.fog_provider = 'fog/openstack'
 config.fog_credentials = {
    :provider              => 'OpenStack',
    :openstack_username    => ENV['OS_USERNAME'],
    :openstack_api_key => ENV['OS_USER_MDP'],
    :openstack_auth_url => ENV['OS_AUTH_URL'],
    :openstack_region    => 'GRA1'
  }

end
7 months ago

I found a solution --> update my ruby version ;) and a better connection

Cancel
Submit your answer